prerogative

Author Topic: VMT not exporting / no textures in Source Model Viewer  (Read 1465 times)

Z3D5

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Acolyte
    • View Profile
VMT not exporting / no textures in Source Model Viewer
« on: February 03, 2017, 06:11:35 AM »
I'm a new user of WallWorm and I'm trying to import a set of brushes from Hammer into 3dsm and then export as a prop static for use in Source.
So far I've had no trouble importing the model with textures, but exporting has been incredibly troublesome.

When I export, I end up with this: http://imgur.com/mepqm4a
The model loads fine, but the textures are missing. As you can see, the issue appears to be that VMT can't be found for the model. When I browse to the VMT Dir as per the Material Folder path, I can see the VTF files that have been generated, but I can't find the VMT file/s which should also have been generated: http://imgur.com/Joe9CXp

These are the export settings I'm using with the texture exporter: http://imgur.com/Znol2w9
Here's how it looks in 3DSM alongside the WWMT UI settings: http://imgur.com/a/LQ0kd

I'm not really sure where to go from here in order to get the VMT to export and the model textures to show?

wallworm

  • Administrator
  • Hero Member
  • *****
  • Posts: 3465
  • Karma: 98
  • Behind me?
    • View Profile
Re: VMT not exporting / no textures in Source Model Viewer
« Reply #1 on: February 03, 2017, 10:21:39 AM »
Welcome to WW :)

When converting brushes to models, there are some considerations. The materials on brushes are usually not valid model materials. Generally, they are lightmappedgeneric. That is consideration #1. The second consideration is that the model settings (that are generated in the QC file) determine where the materials are derived, by default. In your scene, the VMT files are being looked for in "myproject/roof".

For some understanding on the steps to properly getting materials to work, read the Convert Scene to Model docs. I will likely make a function to automate the material steps in the next update to WW.

Z3D5

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Acolyte
    • View Profile
Re: VMT not exporting / no textures in Source Model Viewer
« Reply #2 on: February 03, 2017, 08:14:29 PM »
Many thanks for the help!  :D
I followed the instructions in the link provided and was able to export everything perfectly!

wallworm

  • Administrator
  • Hero Member
  • *****
  • Posts: 3465
  • Karma: 98
  • Behind me?
    • View Profile
Re: VMT not exporting / no textures in Source Model Viewer
« Reply #3 on: February 03, 2017, 08:26:59 PM »
Great to hear.

I updated the Convert Scene to Model floater today. With the new option to Convert VertexLitGeneric, it will now make a copy of materials and change them to VertexLitGeneric if they are anything else. So that should speed it up. Note it won't work on blend or 4way blend... so those have to be dealt with separately.