Author Topic: Collision model weirdness?  (Read 59 times)

Anonyma

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
  • Acolyte
    • View Profile
Collision model weirdness?
« on: August 07, 2017, 10:24:51 PM »
So after downloading wall worm v3.196 on 3ds max 2017 after a bit of a hiatus, I started modeling for Garry's Mod only to find that now all of my collision models seem way, way off.

My typical workflow is:
Make reference model > skin to static_prop > export > make collision model > delete reference model > skin to static_prop > export

So I'm really unsure if this is a fault of my own or a bug with wall worm.

Here's some images to help explain




Oddly enough, the static_prop is moved to directly below the collision model.
What's stranger, is that the second image conflicts with how it actually acts ingame, as ingame the reference model hovers an inch above the ground, yet my save of my reference model is below the collision?

My guess is that the exporter is wildly changing the models somehow.
I hope there's some way I can fix this, thanks for your time either way.

Joris Ceoen

  • Global Moderator
  • Full Member
  • *****
  • Posts: 206
  • Karma: +22/-0
  • WallWorm Ambassador
    • View Profile
    • GamingReviews
Re: Collision model weirdness?
« Reply #1 on: August 08, 2017, 10:22:07 AM »
Select the collision models, and apply an Xform Reset onto them, that usually fixes a lot of problems if you've been dabbling with the pivot point etc...
de_cathedral (WWMT map: http://csgo.gamebanana.com/maps/181217)
de_pontifici (WWMT map: http://www.wallworm.net/index.php/topic,1261.0.html)
space_marble_unlimited (WWMT map: http://csgo.gamebanana.com/maps/185591)
surf_greatriver_2015 (WWMT map: http://csgo.gamebanana.com/maps/187811)

wallworm

  • Administrator
  • Hero Member
  • *****
  • Posts: 3321
  • Karma: +95/-1
  • Behind me?
    • View Profile
    • Wall Worm Tools
Re: Collision model weirdness?
« Reply #2 on: August 08, 2017, 10:29:57 AM »
The exporter doesn't wildly throw things about :) This is likely simply a lack of understanding of different settings in the exporter.

Your method for import/export is a little but awkward and doesn't really fit with the general WW pipeline. I'm busy ATM but will give you a better response later today.
Shawn Olson
Author of the Wall Worm Model Tools

Anonyma

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
  • Acolyte
    • View Profile
Re: Collision model weirdness?
« Reply #3 on: August 09, 2017, 01:01:12 AM »
Thanks, I was wondering if it was my workflow that was flawed.

I've basically had to self-teach myself working in the source engine