3ds Max Crashes when importing De Nuke map models with WallWorm

Started by lauris47, November 01, 2018, 12:05:15 PM

Previous topic - Next topic


I tried with two version of 3ds Max 2018 and 2019.
In both cases program will crash whenever I try to import models with Prop Zoo From VMF File.

I do not necessarily need to import props like that, but it is only way to get materials working on map. program will not crash if I only import whole map, however models won't be with materials.

I have imported around 8 maps like that and Max has not crashed, it happens only on this map.
Anyone has any idea of why this is happening?

Thank you.



I had a crash when importing the de_nuke_zoo.vmf as well.

But I did get de_nuke.vmf to fully import correctly. See attached image.

I used the Batch Level Importer and the settings in screen shot.


Thank you for the reply and testing.
I am trying to batch import, but probably doing something wrong.
I tried your settings, although I cannot see full Folder, but I assume that is maps folder as also explained in the documentation.
Is the Map List direct link to the map file? I tried that too, but no luck. Other settings are the same as in your screenshot.
I tried in both 3ds Max version, also update 2018 to 2018.4 as noted at the bottom of the UI.

When I press run Import now, I see black CMD window for less than a second and nothing happens.

(PS1 that is the old De_Nuke version in your screenshot)
(PS2 I noticed that with every model import 3ds Max interface will be accessible. I used that to my benefit, I was keep saving file until it crashed)


The batch importer may not work in some drive configurations. For example, with my SteamLibrary on the F drive and Max on my C drive, I got the same results as you (CMD flash). So in my case I saved out the batch file instead onto my C drive and executed it from there. So save it to your desktop as importnuke.bat or the likes. It might run with that method.

As for the version I imported, it was just the version that is in my CSGO sdk_content maps. I assumed it was the latest.

It is possible there is some new MDL format that WW isn't prepared to handle that is causing the crash. I'll look into it as time permits.


Also, I did not answer all your questions. The Map Folder was not necessary since I added an actual full map path in the map list. The folder is necessary if you are importing multiple maps in the same folder and don't pass a list. It was just already in my defaults.

SMF spam blocked by CleanTalk