Materials moved to a library to use in alternative maps export corrupted vtf's

Started by the6thmonkey, May 02, 2017, 10:59:49 PM

Previous topic - Next topic


I am unfortunately experiencing a problem with corrupted exported vtf's.
The materials that I am having issues were used fine in another map.
I used the material tools in 3dsmax to save the materials into a group so they could be used again in a new project.
Initially the materials were renamed to "the6thmonkeys_material #1" and I figured I'd simply have to rename the material back to "the6thmonkeys_material" when moved into my new project to fix the texture issue.  Unfortunately exporting the renamed texture still yielded corrupted files. 
I tried opening the vtf's in photoshop (I have the photoshop vtf plugin installed) to to see if the files were okay and this yielded an error. 


I need a lot more information. I don't really have a clear grasp on any of the steps nor problems. Are you saying you are incapable of exporting ANY vtf correctly? Is it just the materials from a specific file? What errors are happening? Etc.


Okay I'll try and do it in steps:
1.  I'm making a map and used the material view to make a bitmap into into standard texture for it.
2.  I exported the textures with wallworm and they worked fine in game (normal creation of materials and exporting is fine).
3.  I liked the textures I created and wanted to include them in a different map I was making.  As a result of this I added the textures I wanted to carry over, into a material library in the 3dsmax material view.
4.  I created my new map and went to my material library in 3dsmax where I was storing the textures I liked and dragged into the material view for the new map
5.  At this point I tried exporting the map, but found that the textures I'd used from my library were checkered black and purple in game.
6.  Upon investigation I found that the standard materials carried over had "#1" appended to the end of their names, and so had the ingame exported textures.
7.  To try and resolve this problem I removed the "#1" from the material names and exported again.
8.  At this stage the materials were named correctly and exporting with this correct name, but I was still getting the checkered black and purple error pattern ingame.
9.  Next I decided to test to see if the vtf's that were being exported actually opened in photoshop, using the installed plugin. 
I found that the exported texture I tested was corrupt (It opened with the message "Could not complete your request because v|ImageLoadProc() failed.") and would not open.
11.  I then tested a regular vtf that already existed in the mod and had no issue.

I understand that I could have used the wallworm material library generator to fetch working versions of the textures for other maps if required but I felt simply moving the materials I liked into a library in 3dsmax as I made them, to use elsewhere was more convenient for me.
Obviously this is not the case right now due to this issue but it would nice to have the option, in the future. 
If you need any further clarification of the steps please ask.


OK, I have a better understanding of your problem.

The VTF files are not necessarily corrupt. I have a suspicion that they were simply created with a VTF version not supported by your mod or by your Photoshop plugin.

To test this, drag and drop the VTF from your windows explorer into an empty area of the Slate View. If it opens (which it should since you have WW Pro) then it means the VTF is valid. But when you exported it you may have had your settings to use a higher VTF version than supported by your targets.

Fix Global VTF Version:

  • Click Wall Worm > Wall Worm Settings
  • Open Materials tab
  • Set VTF Version to one appropriate for mod (7.4 is likely most compatible, though some very old mods might not support it)

Fix individual VTFs:

  • Open Bitmap in Slate
  • If Override Version is on, turn it off so it uses the global setting
  • Click the Export Texture as VTF button (to the far right of the Scale spinner)


Thanks for the help, the issue was indeed caused by using the incorrect vtf version for the mod.

SMF spam blocked by CleanTalk